Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Server Offline - Porty?
#1
Cześć!
Zmagam się ze stworzeniem serwera, po postawieniu vps (Ubuntu 18), wgraniu wszystkich plików, bibliotek etc. udało mi się uruchomić plik i niby wszystko śmiga, ale zupełnie nie da się z nim połączyć. Zwróciłem szczególną uwagę na komunikat " Unknown bind___ () error -1 " (już w aplikacji serwera) który nie pojawia się kiedy odpalam plik ręcznie na swoim komputerze. Serwer pozostaje offline.

Wertując poprzednie posty w tych tematach dotarłem do informacji, że problem może być w nieodblokowanych portach i mimo, że próbowałem coś z tym zrobić (nie wiem na ile mi się to udało), cały czas jest to samo. 

Ma ktoś może pomysł co idzie nie tak?
#2
Może na początek spróbuj zmienić port serwera w config.xml?

Tutaj masz temat, który pozwoli ci odnaleźć która aplikacja już korzysta z tego portu:
https://www.cyberciti.biz/faq/unix-linux...e-command/
#3
Niestety zmiana portu nie rozwiązuje problemu. Nadal to samo.
#4
Jest jeszcze jedna ważna rzecz, g2o korzysta jeszcze z portu serverPort + 5 do komunikacji poprzez protokół http.
Wypisz sobie wszystkie używane porty i upewnij się że serverPort oraz port o 5 większy są wolne.
#5
Nie ważne co zrobię, błąd jest cały czas ten sam. Porty na 100% są zwolnione.
#6
Jakiego firewalla używasz? W jaki sposób odblokowałeś porty na vpsie? Korzystasz z usług Google Cloud bądź AWS?

O jakim błędzie mówisz, wstaw proszę screenshota błędu który otrzymujesz podczas próby nawiązania połączenia z serwerem.

" Unknown bind___ () error -1" oznacza że nie udało się odpalić nasłuchu serwera na protokole ipv6, nie masz się czym przejmować. Ta funkcjonalność po prostu nie działa na obecnej wersji i każdy widzi ten komunikat w konsoli, jednakże nie wpływa on na działanie serwera.
#7
Korzystam z Google Cloud.

Błąd przy nawiązaniu połączenia to standardowe "This server is offline".

Co do firewalla i portów, zabij mnie, ale nie bardzo wiem co odpowiedzieć, jestem jeszcze zielony jeżeli chodzi o te sprawy. Korzystałem z komendy ufw allow *port* i ufw allow *port/tcp* ale nic to nie zmienia.



Podrzucam screena ufw status verbose na wypadek gdyby moje wyjaśnienia były błędne.
https://i.imgur.com/bpi2BjF.png
#8
Z tego co wiem na Google Cloud nad twoim firewallem działa jeszcze ich. W panelu Google Cloud musisz dodać podobne reguły co w ufw i będzie hulało.

Być może to się okaże pomocne: https://cloud.google.com/vpc/docs/using-firewalls
#9
Więc, odblokowałem porty w firewallu Google Cloud... i nic. Serwer nadal jest offline.
#10
użyj czegoś innego. https://firstbyte.ru/ ja tu płacę chyba 30zł na rok
[Image: CPCFNwD.png]


Possibly Related Threads…
Thread Author Replies Views Last Post
Smile no response from http server Piootrek86 2 1,252 16.09.2020, 16:11
Last Post: Piootrek86
  No response from https server Jakubbb 0 918 17.03.2020, 19:06
Last Post: Jakubbb
  No response from http server! Dex 3 2,257 28.11.2019, 19:48
Last Post: Profesores
  Cannot connect with the Master Server. imperior5 4 3,061 02.11.2016, 02:34
Last Post: Nubzior
  Błąd przy wbiciu na server Leo 2 2,004 27.07.2016, 21:07
Last Post: Leo
  [Server] Crashe po wbiciu na serwa. Spray 14 6,745 27.05.2016, 20:58
Last Post: Bimbol
  Server pseudo co-op - Jak to zrobić? Horrilon 5 3,217 08.01.2016, 14:56
Last Post: Horrilon

Forum Jump:


Users browsing this thread: 1 Guest(s)